Contents > 4 The SDMetrics User Interface > 4.3 Calculating and Viewing Metric Data

4.3 Calculating and Viewing Metric Data

After you specified your project file and filter settings (see Section 4.2 "Specifying Project Settings"), select "Project->Calculate Metrics" from the menu bar, or click the Calculate
Button button on the tool bar. SDMetrics will read your UML design file and calculate the metrics as specified. This is a fully automated process that usually takes a few seconds. You can monitor the calculation progress on the status bar.

If an error occurs during data processing (e.g., a file was not found, metric calculation failed due to a semantic error in a custom metric definition file), the calculation will abort and you are prompted with a description and location of the error. After you fixed the error (e.g., specified the correct project file, corrected the metric definition file), press the Calculate Button button again to restart the calculation.

Upon successful completion, you can explore the metric data in the main window. SDMetrics provides several views:

View nameDescription
Metric Data TablesPresents metric data as a set of tables
HistogramsDisplays histograms for the metrics
Kiviat DiagramsDisplays Kiviat diagrams for the model elements
Rule CheckerShows design rule violations for the UML model
Design ComparisonCompares metric values to those of a second UML model
Relation MatricesShows relations such as "class uses class", "actor associated with use case"
Descriptive StatisticsConcise summary of the descriptive statistics for the metric data
Graph StructuresShows circular dependencies and connected components in model element relation graphs
ModelDisplays the UML model in a tabular format
CatalogShows the definitions of all metrics, design rules, and relation matrices
LogKeeps a log of previous calculation runs
Table 2: Overview of SDMetrics' views

To open a view, use the "Views" menu from the menu bar. The following views are also accessible via toolbar buttons: Metric Data Tables (Metric Data Tables), Histograms (Histograms), Kiviat Diagrams (Kiviat Diagrams), and the Rule Checker view (Rule Checker).

Many views allow for navigation to other views. For example, views displaying metric data provide links to the "Catalog" view to display the definition of the metrics, and links to the "Histogram" view to view the distribution of the metrics. After following such links, the history buttons History backHistory forward on the toolbar navigate back and forth between the previously visited views.

4.3.1 Common controls in views